Skip to content

← Public intelligence

Maven package

org.apache.geronimo.plugins:console

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Apache Geronimo Application Server multiple directory traversal vulnerabilities

    CVE-2008-5518 · GHSA-xm92-rf24-h74w

    Affected
    • Maven org.apache.geronimo.plugins:console >= 2.1.0, < 2.1.4
    Fixed in
    2.1.4· Vendor fix available
    Issue
    Multiple directory traversal vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 on Windows allow remote attackers to upload files to arbitrary directories via directory traversal sequences in the (1) group, (2) artifact, (3) version, or (4) fileType parameter to console/portal//Services/Repository (aka the Services/Repository portlet); the (5) createDB parameter to console/portal/Embedded DB/DB Manager (aka the Embedded DB/DB Manager portlet); or the (6) filename parameter to the createKeystore script in the Security/Keystores portlet.

    Recommended action: Upgrade to 2.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedMavenPublished

    Apache Geronimo Application Server CSRF vulnerabilities

    CVE-2009-0039 · GHSA-678x-xfp4-r92r

    Affected
    • Maven org.apache.geronimo.plugins:console < 2.1.4
    Fixed in
    2.1.4· Vendor fix available
    Issue
    Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to hijack the authentication of administrators for requests that (1) change the web administration password, (2) upload applications, and perform unspecified other administrative actions, as demonstrated by (3) a Shutdown request to console/portal//Server/Shutdown.

    Recommended action: Upgrade to 2.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Apache Geronimo Application Server multiple cross-site scripting (XSS) vulnerabilities

    CVE-2009-0038 · GHSA-c372-x57p-6x7v

    Affected
    • Maven org.apache.geronimo.plugins:console >= 2.1.0, < 2.1.4
    Fixed in
    2.1.4· Vendor fix available
    Issue
    Multiple cross-site scripting (XSS) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to inject arbitrary web script or HTML via the (1) name, (2) ip, (3) username, or (4) description parameter to console/portal/Server/Monitoring; or (5) the PATHINFO to the default URI under console/portal/.

    Recommended action: Upgrade to 2.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →