Apache Geronimo Application Server CSRF vulnerabilities
CVE-2009-0039GHSA-678x-xfp4-r92r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.geronimo.plugins:console 2.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.geronimo.plugins:console
- Affected
- < 2.1.4
- Fixed in
- 2.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-678x-xfp4-r92r lists affected ranges: Maven org.apache.geronimo.plugins:console >=0 <2.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2009-0039: 11.06% estimated exploitation activity in the next 30 days; percentile 95.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to hijack the authentication of administrators for requests that (1) change the web administration password, (2) upload applications, and perform unspecified other administrative actions, as demonstrated by (3) a Shutdown request to console/portal//Server/Shutdown.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-678x-xfp4-r92r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-0039 Advisory: Apache Geronimo Application Server CSRF vulnerabilities IDs: CVE-2009-0039, GHSA-678x-xfp4-r92r Record: https://patchnext.com/advisories/cve-2009-0039 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.geronimo.plugins:console 2.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.geronimo.plugins:console: affected < 2.1.4; fixed in 2.1.4 ## Suggested inspection (read-only) - Maven org.apache.geronimo.plugins:console: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.geronimo.plugins:console. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-678x-xfp4-r92r (GitHub-reviewed advisory GHSA-678x-xfp4-r92r lists affected ranges: Maven org.apache.geronimo.plugins:console >=0 <2.1.4) Commands are suggestions: review each one before running it.
Loading voting…