Skip to content

← Public intelligence

Maven package

org.apache.flume.flume-ng-sources:flume-jms-source

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Apache Flume vulnerable to remote code execution via deserialization of unsafe providerURL

    CVE-2022-42468 · GHSA-9w4g-fp9h-3q2v

    Affected
    • Maven org.apache.flume.flume-ng-sources:flume-jms-source < 1.11.0
    Fixed in
    1.11.0· Vendor fix available
    Issue
    Flume’s JMSSource class can be configured with a providerUrl parameter. A JNDI lookup is performed on this name without performing validation. This could result in untrusted data being deserialized, leading to remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed in version 1.11.0.

    Recommended action: Upgrade to 1.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Remote code execution in Apache Flume

    CVE-2022-34916 · GHSA-h9mh-mgpv-gqmv

    Affected
    • Maven org.apache.flume.flume-ng-sources:flume-jms-source >= 1.4.0, < 1.10.1
    Fixed in
    1.10.1· Vendor fix available
    Issue
    Apache Flume versions 1.4.0 through 1.10.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

    Recommended action: Upgrade to 1.10.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Remote Code Execution in Apache Flume

    CVE-2022-25167 · GHSA-x5m7-rwfx-w7qm

    Affected
    • Maven org.apache.flume.flume-ng-sources:flume-jms-source >= 1.4.0, < 1.10.0
    Fixed in
    1.10.0· Vendor fix available
    Issue
    Apache Flume versions 1.4.0 through 1.9.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

    Recommended action: Upgrade to 1.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →