Skip to content

← Actionable
Critical, CVSS 9.8

Apache Flume vulnerable to remote code execution via deserialization of unsafe providerURL

CVE-2022-42468GHSA-9w4g-fp9h-3q2v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.flume.flume-ng-sources:flume-jms-source 1.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-42468: 3.72% estimated exploitation activity in the next 30 days; percentile 89.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Flume’s JMSSource class can be configured with a providerUrl parameter. A JNDI lookup is performed on this name without performing validation. This could result in untrusted data being deserialized, leading to remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed in version 1.11.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9w4g-fp9h-3q2v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-42468

Advisory: Apache Flume vulnerable to remote code execution via deserialization of unsafe providerURL
IDs: CVE-2022-42468, GHSA-9w4g-fp9h-3q2v
Record: https://patchnext.com/advisories/cve-2022-42468 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.flume.flume-ng-sources:flume-jms-source 1.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.flume.flume-ng-sources:flume-jms-source: affected < 1.11.0; fixed in 1.11.0

## Suggested inspection (read-only)
- Maven org.apache.flume.flume-ng-sources:flume-jms-source: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.flume.flume-ng-sources:flume-jms-source.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9w4g-fp9h-3q2v (GitHub-reviewed advisory GHSA-9w4g-fp9h-3q2v lists affected ranges: Maven org.apache.flume.flume-ng-sources:flume-jms-source >=0 <1.11.0)

Commands are suggestions: review each one before running it.

Loading voting…