Medium, CVSS 5.1MavenPublished
Apache Flink CDC is vulnerable to SQL Injection through maliciously crafted identifiers
CVE-2025-62228 · GHSA-wqm3-w3p6-xjgm
- Affected
- Maven org.apache.flink:flink-connector-oracle-cdc >= 3.0.0, < 3.5.0
- Fixed in
- 3.5.0· Vendor fix available
- Issue
- Apache Flink CDC version 3.0.0 to before 3.5.0 are vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, users are recommended to update Flink CDC version to 3.5.0 which address this issue.
Recommended action: Upgrade to 3.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.