Apache Flink CDC is vulnerable to SQL Injection through maliciously crafted identifiers
CVE-2025-62228GHSA-wqm3-w3p6-xjgm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.flink:flink-connector-db2-cdc 3.5.0; org.apache.flink:flink-connector-mysql-cdc 3.5.0; org.apache.flink:flink-connector-oracle-cdc 3.5.0; org.apache.flink:flink-cdc-pipeline-connectors 3.5.0; org.apache.flink:flink-connector-sqlserver-cdc 3.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.flink:flink-connector-db2-cdc
- Affected
- >= 3.0.0, < 3.5.0
- Fixed in
- 3.5.0
Maven org.apache.flink:flink-connector-mysql-cdc
- Affected
- >= 3.0.0, < 3.5.0
- Fixed in
- 3.5.0
Maven org.apache.flink:flink-connector-oracle-cdc
- Affected
- >= 3.0.0, < 3.5.0
- Fixed in
- 3.5.0
Maven org.apache.flink:flink-cdc-pipeline-connectors
- Affected
- >= 3.0.0, < 3.5.0
- Fixed in
- 3.5.0
Maven org.apache.flink:flink-connector-sqlserver-cdc
- Affected
- >= 3.0.0, < 3.5.0
- Fixed in
- 3.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wqm3-w3p6-xjgm lists affected ranges: Maven org.apache.flink:flink-cdc-pipeline-connectors >=3.0.0 =3.0.0 =3.0.0 =3.0.0 =3.0.0 <3.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L · score source
- EPSS
- CVE-2025-62228: 0.46% estimated exploitation activity in the next 30 days; percentile 39.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Flink CDC version 3.0.0 to before 3.5.0 are vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, users are recommended to update Flink CDC version to 3.5.0 which address this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wqm3-w3p6-xjgm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62228 Advisory: Apache Flink CDC is vulnerable to SQL Injection through maliciously crafted identifiers IDs: CVE-2025-62228, GHSA-wqm3-w3p6-xjgm Record: https://patchnext.com/advisories/cve-2025-62228 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.flink:flink-connector-db2-cdc 3.5.0; org.apache.flink:flink-connector-mysql-cdc 3.5.0; org.apache.flink:flink-connector-oracle-cdc 3.5.0; org.apache.flink:flink-cdc-pipeline-connectors 3.5.0; org.apache.flink:flink-connector-sqlserver-cdc 3.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.flink:flink-connector-db2-cdc: affected >= 3.0.0, < 3.5.0; fixed in 3.5.0 - Maven org.apache.flink:flink-connector-mysql-cdc: affected >= 3.0.0, < 3.5.0; fixed in 3.5.0 - Maven org.apache.flink:flink-connector-oracle-cdc: affected >= 3.0.0, < 3.5.0; fixed in 3.5.0 - Maven org.apache.flink:flink-cdc-pipeline-connectors: affected >= 3.0.0, < 3.5.0; fixed in 3.5.0 - Maven org.apache.flink:flink-connector-sqlserver-cdc: affected >= 3.0.0, < 3.5.0; fixed in 3.5.0 ## Suggested inspection (read-only) - Maven org.apache.flink:flink-connector-db2-cdc: check the installed version with your package manager. - Maven org.apache.flink:flink-connector-mysql-cdc: check the installed version with your package manager. - Maven org.apache.flink:flink-connector-oracle-cdc: check the installed version with your package manager. - Maven org.apache.flink:flink-cdc-pipeline-connectors: check the installed version with your package manager. - Maven org.apache.flink:flink-connector-sqlserver-cdc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.flink:flink-connector-db2-cdc, org.apache.flink:flink-connector-mysql-cdc, org.apache.flink:flink-connector-oracle-cdc, org.apache.flink:flink-cdc-pipeline-connectors, org.apache.flink:flink-connector-sqlserver-cdc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wqm3-w3p6-xjgm (GitHub-reviewed advisory GHSA-wqm3-w3p6-xjgm lists affected ranges: Maven org.apache.flink:flink-cdc-pipeline-connectors >=3.0.0 =3.0.0 =3.0.0 =3.0.0 =3.0.0 <3.5.0) Commands are suggestions: review each one before running it.
Loading voting…