Critical, CVSS 9.8MavenPublished
Apache Flex BlazeDS unsafe deserialization
CVE-2017-5641 · GHSA-w8v7-prhw-xjpw
- Affected
- Maven org.apache.flex.blazeds:flex-messaging-remoting <= 4.7.2
- Fixed in
- 4.7.3· Vendor fix available
- Issue
- Previous versions of Apache Flex BlazeDS (4.7.2 and earlier) did not restrict which types were allowed for AMF(X) object deserialization by default. During the deserialization process code is executed that for several known types has undesired side-effects. Other, unknown types may also exhibit such behaviors. One vector in the Java standard library exists that allows an attacker to trigger possibly further exploitable Java deserialization of untrusted data. Other known vectors in third party libraries can be used to trigger remote code execution.
Recommended action: Upgrade to 4.7.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.