Apache Flex BlazeDS unsafe deserialization
CVE-2017-5641GHSA-w8v7-prhw-xjpw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.flex.blazeds:flex-messaging-remoting 4.7.3; org.apache.flex.blazeds:flex-messaging-core 4.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.flex.blazeds:flex-messaging-remoting
- Affected
- <= 4.7.2
- Fixed in
- 4.7.3
Maven org.apache.flex.blazeds:flex-messaging-core
- Affected
- <= 4.7.2
- Fixed in
- 4.7.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w8v7-prhw-xjpw lists affected ranges: Maven org.apache.flex.blazeds:flex-messaging-core >=0 =0 <=4.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-5641: 20.75% estimated exploitation activity in the next 30 days; percentile 97.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Previous versions of Apache Flex BlazeDS (4.7.2 and earlier) did not restrict which types were allowed for AMF(X) object deserialization by default. During the deserialization process code is executed that for several known types has undesired side-effects. Other, unknown types may also exhibit such behaviors. One vector in the Java standard library exists that allows an attacker to trigger possibly further exploitable Java deserialization of untrusted data. Other known vectors in third party libraries can be used to trigger remote code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w8v7-prhw-xjpw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-5641 Advisory: Apache Flex BlazeDS unsafe deserialization IDs: CVE-2017-5641, GHSA-w8v7-prhw-xjpw Record: https://patchnext.com/advisories/cve-2017-5641 (revision 1, source checked 26 Oct 2026, 16:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.flex.blazeds:flex-messaging-remoting 4.7.3; org.apache.flex.blazeds:flex-messaging-core 4.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.flex.blazeds:flex-messaging-remoting: affected <= 4.7.2; fixed in 4.7.3 - Maven org.apache.flex.blazeds:flex-messaging-core: affected <= 4.7.2; fixed in 4.7.3 ## Suggested inspection (read-only) - Maven org.apache.flex.blazeds:flex-messaging-remoting: check the installed version with your package manager. - Maven org.apache.flex.blazeds:flex-messaging-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.flex.blazeds:flex-messaging-remoting, org.apache.flex.blazeds:flex-messaging-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w8v7-prhw-xjpw (GitHub-reviewed advisory GHSA-w8v7-prhw-xjpw lists affected ranges: Maven org.apache.flex.blazeds:flex-messaging-core >=0 =0 <=4.7.2) Commands are suggestions: review each one before running it.
Loading voting…