Skip to content

← Public intelligence

Maven package

org.apache.dubbo:dubbo-parent

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Apache Dubbo vulnerable to remote code execution via Telnet Handler

    CVE-2021-32824 · GHSA-fprr-rrm8-4534

    Affected
    • Maven org.apache.dubbo:dubbo-parent < 2.6.10; >= 2.7.0, < 2.7.10
    Fixed in
    2.7.102.6.10· Vendor fix available
    Issue
    Apache Dubbo is a Java based, open source RPC framework. Versions prior to 2.6.10 and 2.7.10 are vulnerable to pre-authorization remote code execution via arbitrary bean manipulation in the Telnet handler. The Dubbo main service port can be used to access a Telnet Handler which offers some basic methods to collect information about the providers and methods exposed by the service and it can even allow to shutdown the service. This endpoint is unprotected. Additionally, a provider method can be invoked using the invoke handler. This handler uses a safe version of FastJson to process the call arguments. However, the resulting list is later processed with PojoUtils.realize which can be used to instantiate arbitrary classes and invoke its setters. Even though FastJson is properly protected with a default blocklist, PojoUtils.realize is not, and an attacker can leverage that to achieve remote code execution. Versions 2.6.10 and 2.7.10 contain fixes for this issue.

    Recommended action: Upgrade to 2.7.10 or 2.6.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Deserialization exploitation in Apache Dubbo

    CVE-2020-11995 · GHSA-74mg-6xqx-2vrq

    Affected
    • Maven org.apache.dubbo:dubbo-parent >= 2.7.0, < 2.7.8; < 2.6.9
    Fixed in
    2.6.92.7.8· Vendor fix available
    Issue
    A deserialization vulnerability existed in dubbo 2.7.5 and its earlier versions, which could lead to malicious code execution. Most Dubbo users use Hessian2 as the default serialization/deserialization protool, during Hessian2 deserializing the HashMap object, some functions in the classes stored in HashMap will be executed after a series of program calls, however, those special functions may cause remote command execution. For example, the hashCode() function of the EqualsBean class in rome-1.7.0.jar will cause the remotely load malicious classes and execute malicious code by constructing a malicious request. This issue was fixed in Apache Dubbo 2.6.9 and 2.7.8.

    Recommended action: Upgrade to 2.7.8 or 2.6.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →