Deserialization exploitation in Apache Dubbo
CVE-2020-11995GHSA-74mg-6xqx-2vrq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.dubbo:dubbo-parent 2.7.8, 2.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.dubbo:dubbo-parent
- Affected
- >= 2.7.0, < 2.7.8< 2.6.9
- Fixed in
- 2.6.9, 2.7.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-74mg-6xqx-2vrq lists affected ranges: Maven org.apache.dubbo:dubbo-parent >=2.7.0 =0 <2.6.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-11995: 5.93% estimated exploitation activity in the next 30 days; percentile 93.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A deserialization vulnerability existed in dubbo 2.7.5 and its earlier versions, which could lead to malicious code execution. Most Dubbo users use Hessian2 as the default serialization/deserialization protool, during Hessian2 deserializing the HashMap object, some functions in the classes stored in HashMap will be executed after a series of program calls, however, those special functions may cause remote command execution. For example, the hashCode() function of the EqualsBean class in rome-1.7.0.jar will cause the remotely load malicious classes and execute malicious code by constructing a malicious request. This issue was fixed in Apache Dubbo 2.6.9 and 2.7.8.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-74mg-6xqx-2vrq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-11995 Advisory: Deserialization exploitation in Apache Dubbo IDs: CVE-2020-11995, GHSA-74mg-6xqx-2vrq Record: https://patchnext.com/advisories/cve-2020-11995 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.dubbo:dubbo-parent 2.7.8, 2.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.dubbo:dubbo-parent: affected >= 2.7.0, < 2.7.8; < 2.6.9; fixed in 2.6.9, 2.7.8 ## Suggested inspection (read-only) - Maven org.apache.dubbo:dubbo-parent: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.dubbo:dubbo-parent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-74mg-6xqx-2vrq (GitHub-reviewed advisory GHSA-74mg-6xqx-2vrq lists affected ranges: Maven org.apache.dubbo:dubbo-parent >=2.7.0 =0 <2.6.9) Commands are suggestions: review each one before running it.
Loading voting…