Low, CVSS 1.7MavenPublished
druid-pac4j, Apache Druid extension, has Padding Oracle vulnerability
CVE-2024-45384 · GHSA-p72w-r6fv-6g5h
- Affected
- Maven org.apache.druid.extensions:druid-pac4j >= 0.18.0, < 30.0.1
- Fixed in
- 30.0.1· Vendor fix available
- Issue
- Padding Oracle vulnerability in Apache Druid extension, druid-pac4j. This could allow an attacker to manipulate a pac4j session cookie. This issue affects Apache Druid versions 0.18.0 through 30.0.0. Since the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability. While we are not aware of a way to meaningfully exploit this flaw, we nevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue and ensuring you have a strong druid.auth.pac4j.cookiePassphrase as a precaution.
Recommended action: Upgrade to 30.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.