Skip to content

← Actionable
Low, CVSS 1.7

druid-pac4j, Apache Druid extension, has Padding Oracle vulnerability

CVE-2024-45384GHSA-p72w-r6fv-6g5h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.druid.extensions:druid-pac4j 30.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.7 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2024-45384: 0.82% estimated exploitation activity in the next 30 days; percentile 57.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Padding Oracle vulnerability in Apache Druid extension, druid-pac4j. This could allow an attacker to manipulate a pac4j session cookie. This issue affects Apache Druid versions 0.18.0 through 30.0.0. Since the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability. While we are not aware of a way to meaningfully exploit this flaw, we nevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue and ensuring you have a strong druid.auth.pac4j.cookiePassphrase as a precaution.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p72w-r6fv-6g5h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45384

Advisory: druid-pac4j, Apache Druid extension, has Padding Oracle vulnerability
IDs: CVE-2024-45384, GHSA-p72w-r6fv-6g5h
Record: https://patchnext.com/advisories/cve-2024-45384 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.druid.extensions:druid-pac4j 30.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.druid.extensions:druid-pac4j: affected >= 0.18.0, < 30.0.1; fixed in 30.0.1

## Suggested inspection (read-only)
- Maven org.apache.druid.extensions:druid-pac4j: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.druid.extensions:druid-pac4j.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p72w-r6fv-6g5h (GitHub-reviewed advisory GHSA-p72w-r6fv-6g5h lists affected ranges: Maven org.apache.druid.extensions:druid-pac4j >=0.18.0 <30.0.1)

Commands are suggestions: review each one before running it.

Loading voting…