Skip to content

← Public intelligence

Maven package

org.apache.commons:commons-configuration2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3MavenPublished

    Apache Commons Configuration: StackOverflowError for YAML input with cycles

    CVE-2026-45205 · GHSA-337m-mw94-2v6g

    Affected
    • Maven org.apache.commons:commons-configuration2 >= 2.2, < 2.15.0
    Fixed in
    2.15.0· Vendor fix available
    Issue
    Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

    Recommended action: Upgrade to 2.15.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.9MavenPublished

    Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree

    CVE-2024-29133 · GHSA-9w38-p64v-xpmv

    Affected
    • Maven org.apache.commons:commons-configuration2 >= 2.0, < 2.10.1
    Fixed in
    2.10.1· Vendor fix available
    Issue
    This Out-of-bounds Write vulnerability in Apache Commons Configuration affects Apache Commons Configuration: from 2.0 before 2.10.1. User can see this as a 'StackOverflowError' calling 'ListDelimiterHandler.flatten(Object, int)' with a cyclical object tree. Users are recommended to upgrade to version 2.10.1, which fixes the issue.

    Recommended action: Upgrade to 2.10.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.5MavenPublished

    Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()

    CVE-2024-29131 · GHSA-xjp4-hw94-mvp5

    Affected
    • Maven org.apache.commons:commons-configuration2 >= 2.0, < 2.10.1
    Fixed in
    2.10.1· Vendor fix available
    Issue
    This Out-of-bounds Write vulnerability in Apache Commons Configuration affects Apache Commons Configuration: from 2.0 before 2.10.1. User can see this as a 'StackOverflowError' when adding a property in 'AbstractListDelimiterHandler.flattenIterator()'. Users are recommended to upgrade to version 2.10.1, which fixes the issue.

    Recommended action: Upgrade to 2.10.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8MavenPublished

    Code injection in Apache Commons Configuration

    CVE-2022-33980 · GHSA-xj57-8qj4-c4m6

    Affected
    • Maven org.apache.commons:commons-configuration2 >= 2.4, < 2.8.0
    Fixed in
    2.8.0· Vendor fix available
    Issue
    Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the…

    Recommended action: Upgrade to 2.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 10.0MavenPublished

    Remote code execution in Apache Commons Configuration

    CVE-2020-1953 · GHSA-7qx4-pp76-vrqh

    Affected
    • Maven org.apache.commons:commons-configuration2 >= 2.2, < 2.7
    Fixed in
    2.7· Vendor fix available
    Issue
    Apache Commons Configuration uses a third-party library to parse YAML files which by default allows the instantiation of classes if the YAML includes special statements. Apache Commons Configuration versions 2.2, 2.3, 2.4, 2.5, 2.6 did not change the default settings of this library. So if a YAML file was loaded from an untrusted source, it could therefore load and execute code out of the control of the host application.

    Recommended action: Upgrade to 2.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →