Code injection in Apache Commons Configuration
CVE-2022-33980GHSA-xj57-8qj4-c4m6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.commons:commons-configuration2 2.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.commons:commons-configuration2
- Affected
- >= 2.4, < 2.8.0
- Fixed in
- 2.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xj57-8qj4-c4m6 lists affected ranges: Maven org.apache.commons:commons-configuration2 >=2.4 <2.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-33980: 44.64% estimated exploitation activity in the next 30 days; percentile 98.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xj57-8qj4-c4m6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-33980 Advisory: Code injection in Apache Commons Configuration IDs: CVE-2022-33980, GHSA-xj57-8qj4-c4m6 Record: https://patchnext.com/advisories/cve-2022-33980 (revision 1, source checked 26 Oct 2026, 16:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.commons:commons-configuration2 2.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.commons:commons-configuration2: affected >= 2.4, < 2.8.0; fixed in 2.8.0 ## Suggested inspection (read-only) - Maven org.apache.commons:commons-configuration2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.commons:commons-configuration2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xj57-8qj4-c4m6 (GitHub-reviewed advisory GHSA-xj57-8qj4-c4m6 lists affected ranges: Maven org.apache.commons:commons-configuration2 >=2.4 <2.8.0) Commands are suggestions: review each one before running it.
Loading voting…