High, CVSS 8.1MavenPublished
Apache Camel can allow remote attackers to execute arbitrary commands
CVE-2015-5348 · GHSA-26v6-w6fw-rh94
- Affected
- Maven org.apache.camel:camel-servlet < 2.15.5; >= 2.16.0, <= 2.16.0
- Fixed in
- 2.15.52.16.1· Vendor fix available
- Issue
- Apache Camel 2.6.x through 2.14.x, 2.15.x before 2.15.5, and 2.16.x before 2.16.1, when using (1) camel-jetty or (2) camel-servlet as a consumer in Camel routes, allow remote attackers to execute arbitrary commands via a crafted serialized Java object in an HTTP request.
Recommended action: Upgrade to 2.16.1 or 2.15.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.