Skip to content

← Actionable
High, CVSS 8.1

Apache Camel can allow remote attackers to execute arbitrary commands

CVE-2015-5348GHSA-26v6-w6fw-rh94

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-ahc 2.16.1, 2.15.5; org.apache.camel:camel-jetty 2.16.1, 2.15.5; org.apache.camel:camel-http-common 2.16.1, 2.15.5; org.apache.camel:camel-http 2.16.1, 2.15.5; org.apache.camel:camel-servlet 2.16.1, 2.15.5; 1 more package under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-26v6-w6fw-rh94 lists affected ranges: Maven org.apache.camel:camel-jetty >=0 =2.16.0 =0 =2.16.0 =0 =2.16.0 =0 =2.16.0 =0 =2.16.0 =0 =2.16.0 <=2.16.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2015-5348: 6.37% estimated exploitation activity in the next 30 days; percentile 93.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Camel 2.6.x through 2.14.x, 2.15.x before 2.15.5, and 2.16.x before 2.16.1, when using (1) camel-jetty or (2) camel-servlet as a consumer in Camel routes, allow remote attackers to execute arbitrary commands via a crafted serialized Java object in an HTTP request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-26v6-w6fw-rh94

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-5348

Advisory: Apache Camel can allow remote attackers to execute arbitrary commands
IDs: CVE-2015-5348, GHSA-26v6-w6fw-rh94
Record: https://patchnext.com/advisories/cve-2015-5348 (revision 1, source checked 26 Oct 2026, 16:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-ahc 2.16.1, 2.15.5; org.apache.camel:camel-jetty 2.16.1, 2.15.5; org.apache.camel:camel-http-common 2.16.1, 2.15.5; org.apache.camel:camel-http 2.16.1, 2.15.5; org.apache.camel:camel-servlet 2.16.1, 2.15.5; org.apache.camel:camel-http4 2.16.1, 2.15.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.camel:camel-ahc: affected < 2.15.5; >= 2.16.0, <= 2.16.0; fixed in 2.15.5, 2.16.1
- Maven org.apache.camel:camel-jetty: affected < 2.15.5; >= 2.16.0, <= 2.16.0; fixed in 2.15.5, 2.16.1
- Maven org.apache.camel:camel-http-common: affected < 2.15.5; >= 2.16.0, <= 2.16.0; fixed in 2.15.5, 2.16.1
- Maven org.apache.camel:camel-http: affected < 2.15.5; >= 2.16.0, <= 2.16.0; fixed in 2.15.5, 2.16.1
- Maven org.apache.camel:camel-servlet: affected < 2.15.5; >= 2.16.0, <= 2.16.0; fixed in 2.15.5, 2.16.1
- Maven org.apache.camel:camel-http4: affected < 2.15.5; >= 2.16.0, <= 2.16.0; fixed in 2.15.5, 2.16.1

## Suggested inspection (read-only)
- Maven org.apache.camel:camel-ahc: check the installed version with your package manager.
- Maven org.apache.camel:camel-jetty: check the installed version with your package manager.
- Maven org.apache.camel:camel-http-common: check the installed version with your package manager.
- Maven org.apache.camel:camel-http: check the installed version with your package manager.
- Maven org.apache.camel:camel-servlet: check the installed version with your package manager.
- Maven org.apache.camel:camel-http4: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.camel:camel-ahc, org.apache.camel:camel-jetty, org.apache.camel:camel-http-common, org.apache.camel:camel-http, org.apache.camel:camel-servlet, org.apache.camel:camel-http4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-26v6-w6fw-rh94 (GitHub-reviewed advisory GHSA-26v6-w6fw-rh94 lists affected ranges: Maven org.apache.camel:camel-jetty >=0 =2.16.0 =0 =2.16.0 =0 =2.16.0 =0 =2.16.0 =0 =2.16.0 =0 =2.16.0 <=2.16.0)

Commands are suggestions: review each one before running it.

Loading voting…