Medium, CVSS 6.9MavenAmendedPublished
Apache Avro Java SDK is Vulnerable to Code Injection
CVE-2025-33042 · GHSA-rp46-r563-jrc7
- Affected
- Maven org.apache.avro:avro-compiler >= 1.12.0, <= 1.12.0; < 1.11.5
- Fixed in
- 1.11.51.12.1· Vendor fix available
- Issue
- Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Avro Java SDK when generating specific records from untrusted Avro schemas. This issue affects Apache Avro Java SDK: all versions through 1.11.4 and version 1.12.0. Users are recommended to upgrade to version 1.12.1 or 1.11.5, which fix the issue.
Recommended action: Upgrade to 1.12.1 or 1.11.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.