Apache Avro Java SDK is Vulnerable to Code Injection
CVE-2025-33042GHSA-rp46-r563-jrc7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.avro:avro-compiler 1.12.1, 1.11.5; avro 1.11.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.avro:avro-compiler
- Affected
- >= 1.12.0, <= 1.12.0< 1.11.5
- Fixed in
- 1.11.5, 1.12.1
PyPI avro
- Affected
- < 1.11.5
- Fixed in
- 1.11.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-26 lists affected ranges: PyPI avro >=0 <1.11.5 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rp46-r563-jrc7 lists affected ranges: Maven org.apache.avro:avro-compiler >=1.12.0 =0 <1.11.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-33042: 0.67% estimated exploitation activity in the next 30 days; percentile 52.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Avro Java SDK when generating specific records from untrusted Avro schemas. This issue affects Apache Avro Java SDK: all versions through 1.11.4 and version 1.12.0. Users are recommended to upgrade to version 1.12.1 or 1.11.5, which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rp46-r563-jrc7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record PYSEC-2026-26
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-33042 Advisory: Apache Avro Java SDK is Vulnerable to Code Injection IDs: CVE-2025-33042, GHSA-rp46-r563-jrc7 Record: https://patchnext.com/advisories/cve-2025-33042 (revision 3, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.avro:avro-compiler 1.12.1, 1.11.5; avro 1.11.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.avro:avro-compiler: affected >= 1.12.0, <= 1.12.0; < 1.11.5; fixed in 1.11.5, 1.12.1 - PyPI avro: affected < 1.11.5; fixed in 1.11.5 ## Suggested inspection (read-only) - Maven org.apache.avro:avro-compiler: check the installed version with your package manager. - `python -m pip show avro`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.avro:avro-compiler, avro. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2026-26 (OSV record PYSEC-2026-26 lists affected ranges: PyPI avro >=0 <1.11.5 (fixed)) - Verified: https://github.com/advisories/GHSA-rp46-r563-jrc7 (GitHub-reviewed advisory GHSA-rp46-r563-jrc7 lists affected ranges: Maven org.apache.avro:avro-compiler >=1.12.0 =0 <1.11.5) Commands are suggestions: review each one before running it.
Loading voting…