Skip to content

← Public intelligence

Maven package

org.apache.archiva:archiva

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

9 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Apache Archiva vulnerable to privilege escalation via stored cross-site scripting (XSS)

    CVE-2023-28158 · GHSA-qf34-f43r-gv9p

    Affected
    • Maven org.apache.archiva:archiva >= 2.0.0, < 2.2.10
    Fixed in
    2.2.10· Vendor fix available
    Issue
    Apache Archiva is vulnerable to privilege escalation vua stored cross-site-scripting using the file upload service to upload malicious content. The issue can be exploited only by authenticated users which can create directory name to inject some XSS content and gain some privileges, such as an admin user.

    Recommended action: Upgrade to 2.2.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5MavenPublished

    Missing Authorization in Apache Archiva

    CVE-2022-29405 · GHSA-5hqc-x78w-3cmw

    Affected
    • Maven org.apache.archiva:archiva < 2.2.8
    Fixed in
    2.2.8· Vendor fix available
    Issue
    In Apache Archiva, any registered user can reset password for any users. This is fixed in Archiva 2.2.8.

    Recommended action: Upgrade to 2.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Apache Continuum and Archiva vulnerable to Cross-site Scripting

    CVE-2011-0533 · GHSA-7382-fv7p-v9v3

    Affected
    • Maven org.apache.archiva:archiva >= 1.0, < 1.3.4
    Fixed in
    1.3.4· Partial vendor fix
    Issue
    Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.

    Recommended action: Upgrade to 1.3.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.9MavenPublished

    Apache Archiva does not require entry of the administrator's password at the time of modifying a user account

    CVE-2010-4408 · GHSA-5p54-jj38-3hxj

    Affected
    • Maven org.apache.archiva:archiva >= 1.0, < 1.3.2
    Fixed in
    1.3.2· Vendor fix available
    Issue
    Apache Archiva 1.0 through 1.0.3, 1.1 through 1.1.4, 1.2 through 1.2.2, and 1.3 through 1.3.1 does not require entry of the administrator's password at the time of modifying a user account, which makes it easier for context-dependent attackers to gain privileges by leveraging a (1) unattended workstation or (2) cross-site request forgery (CSRF) vulnerability, a related issue to CVE-2010-3449.

    Recommended action: Upgrade to 1.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.0MavenPublished

    Apache Archiva vulnerable to Cross Site Request Forgery

    CVE-2017-5657 · GHSA-hf4p-mhc8-x2gp

    Affected
    • Maven org.apache.archiva:archiva < 2.2.3
    Fixed in
    2.2.3· Vendor fix available
    Issue
    Several REST service endpoints of Apache Archiva are not protected against Cross Site Request Forgery (CSRF) attacks. A malicious site opened in the same browser as the archiva site, may send an HTML response that performs arbitrary actions on archiva services, with the same rights as the active archiva session (e.g. administrator rights).

    Recommended action: Upgrade to 2.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 4.8MavenPublished

    Apache Archiva vulnerable to Cross-site Scripting

    CVE-2016-5005 · GHSA-8jfm-rgmg-3wq2

    Affected
    • Maven org.apache.archiva:archiva < 2.2.1
    Fixed in
    2.2.1· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in Apache Archiva prior to version 2.2.1 allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnectorcommit.action.

    Recommended action: Upgrade to 2.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 5.3MavenPublished

    Injection in Apache Archiva

    CVE-2020-9495 · GHSA-v83p-xwm9-v4g8

    Affected
    • Maven org.apache.archiva:archiva < 2.2.5
    Fixed in
    2.2.5· Vendor fix available
    Issue
    Apache Archiva login service before 2.2.5 is vulnerable to LDAP injection. A attacker is able to retrieve user attribute data from the connected LDAP server by providing special values to the login form. With certain characters it is possible to modify the LDAP filter used to query the LDAP users. By measuring the response time for the login request, arbitrary attribute data can be retrieved from LDAP user objects.

    Recommended action: Upgrade to 2.2.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. Medium, CVSS 6.5MavenPublished

    Cross-site scripting in Apache Archiva

    CVE-2019-0213 · GHSA-cqcf-4g4h-rghf

    Affected
    • Maven org.apache.archiva:archiva < 2.2.4
    Fixed in
    2.2.4· Vendor fix available
    Issue
    In Apache Archiva before 2.2.4, it is possible to write files to the archiva server at arbitrary locations by using the artifact upload mechanism. Existing files can be overwritten, if the archiva run user has appropriate permission on the filesystem for the target file.

    Recommended action: Upgrade to 2.2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  9. Medium, CVSS 6.5MavenPublished

    Improper Input Validation in Apache Archiva

    CVE-2019-0214 · GHSA-jxgm-9f58-w4xp

    Affected
    • Maven org.apache.archiva:archiva >= 2.2.0, < 2.2.4
    Fixed in
    2.2.4· Vendor fix available
    Issue
    In Apache Archiva 2.0.0 - 2.2.3, it is possible to write files to the archiva server at arbitrary locations by using the artifact upload mechanism. Existing files can be overwritten, if the archiva run user has appropriate permission on the filesystem for the target file.

    Recommended action: Upgrade to 2.2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →