Skip to content

← Actionable
Medium, CVSS 5.3

Injection in Apache Archiva

CVE-2020-9495GHSA-v83p-xwm9-v4g8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.archiva:archiva 2.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2020-9495: 8.00% estimated exploitation activity in the next 30 days; percentile 94.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Archiva login service before 2.2.5 is vulnerable to LDAP injection. A attacker is able to retrieve user attribute data from the connected LDAP server by providing special values to the login form. With certain characters it is possible to modify the LDAP filter used to query the LDAP users. By measuring the response time for the login request, arbitrary attribute data can be retrieved from LDAP user objects.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v83p-xwm9-v4g8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-9495

Advisory: Injection in Apache Archiva
IDs: CVE-2020-9495, GHSA-v83p-xwm9-v4g8
Record: https://patchnext.com/advisories/cve-2020-9495 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.archiva:archiva 2.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.archiva:archiva: affected < 2.2.5; fixed in 2.2.5

## Suggested inspection (read-only)
- Maven org.apache.archiva:archiva: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.archiva:archiva.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v83p-xwm9-v4g8 (GitHub-reviewed advisory GHSA-v83p-xwm9-v4g8 lists affected ranges: Maven org.apache.archiva:archiva >=0 <2.2.5)

Commands are suggestions: review each one before running it.

Loading voting…