Skip to content

← Public intelligence

Maven package

org.apache.ambari:ambari

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

8 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3MavenPublished

    Apache Ambari: Various Cross site scripting problems

    CVE-2023-50378 · GHSA-9q6v-rxmw-g3gh

    Affected
    • Maven org.apache.ambari:ambari < 2.7.8
    Fixed in
    2.7.8· Vendor fix available
    Issue
    Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8 Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. Users are recommended to upgrade to version 2.7.8 which fixes this issue.

    Recommended action: Upgrade to 2.7.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    Apache Ambari Expression Language Injection vulnerability

    CVE-2022-45855 · GHSA-p7w2-784m-qpq9

    Affected
    • Maven org.apache.ambari:ambari >= 2.7.0, < 2.7.7
    Fixed in
    2.7.7· Vendor fix available
    Issue
    SpringEL injection in the metrics source in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.

    Recommended action: Upgrade to 2.7.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8MavenPublished

    Apache Ambari Expression Language Injection vulnerability

    CVE-2022-42009 · GHSA-m384-pj54-5vr2

    Affected
    • Maven org.apache.ambari:ambari >= 2.7.0, < 2.7.7
    Fixed in
    2.7.7· Vendor fix available
    Issue
    SpringEL injection in the server agent in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.

    Recommended action: Upgrade to 2.7.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. UnratedMavenPublished

    Apache Ambari SSRF Vulnerability

    CVE-2015-1775 · GHSA-9g2j-5685-h44h

    Affected
    • Maven org.apache.ambari:ambari >= 1.5.0, < 2.1.0
    Fixed in
    2.1.0· Vendor fix available
    Issue
    Server-side request forgery (SSRF) vulnerability in the proxy endpoint (api/v1/proxy) in Apache Ambari before 2.1.0 allows remote authenticated users to conduct port scans and access unsecured services via a crafted REST call.

    Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. UnratedMavenPublished

    Apache Ambari Open Redirect

    CVE-2015-5210 · GHSA-w3p6-94x2-xcvm

    Affected
    • Maven org.apache.ambari:ambari >= 1.7.0, < 2.1.2
    Fixed in
    2.1.2· Vendor fix available
    Issue
    Open redirect vulnerability in Apache Ambari before 2.1.2 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a URL in the targetURI parameter.

    Recommended action: Upgrade to 2.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.5MavenPublished

    Apache Ambari reveals administrator passwords

    CVE-2016-4976 · GHSA-q3pw-6vf2-66hf

    Affected
    • Maven org.apache.ambari:ambari >= 2.0.0, < 2.4.0
    Fixed in
    2.4.0· Vendor fix available
    Issue
    Apache Ambari 2.x before 2.4.0 includes KDC administrator passwords on the kadmin command line, which allows local users to obtain sensitive information via a process listing.

    Recommended action: Upgrade to 2.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Critical, CVSS 9.8MavenPublished

    Apache Ambari Improper Access Control

    CVE-2016-6807 · GHSA-j76q-99x2-v7vq

    Affected
    • Maven org.apache.ambari:ambari >= 2.4.0, < 2.4.2
    Fixed in
    2.4.2· Vendor fix available
    Issue
    Custom commands may be executed on Ambari Agent (2.4.x, before 2.4.2) hosts without authorization, leading to unauthorized access to operations that may affect the underlying system. Such operations are invoked by the Ambari Agent process on Ambari Agent hosts, as the user executing the Ambari Agent process.

    Recommended action: Upgrade to 2.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. Medium, CVSS 6.1MavenPublished

    Cross-site Scripting (XSS) in Apache Ambari Views

    CVE-2020-1936 · GHSA-q7q9-w24q-cpgh

    Affected
    • Maven org.apache.ambari:ambari < 2.7.4
    Fixed in
    2.7.4· Vendor fix available
    Issue
    A cross-site scripting issue was found in Apache Ambari Views. This was addressed in Apache Ambari 2.7.4.

    Recommended action: Upgrade to 2.7.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →