Cross-site Scripting (XSS) in Apache Ambari Views
CVE-2020-1936GHSA-q7q9-w24q-cpgh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.ambari:ambari 2.7.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.ambari:ambari
- Affected
- < 2.7.4
- Fixed in
- 2.7.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q7q9-w24q-cpgh lists affected ranges: Maven org.apache.ambari:ambari >=0 <2.7.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-1936: 2.86% estimated exploitation activity in the next 30 days; percentile 86.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A cross-site scripting issue was found in Apache Ambari Views. This was addressed in Apache Ambari 2.7.4.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q7q9-w24q-cpgh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-1936 Advisory: Cross-site Scripting (XSS) in Apache Ambari Views IDs: CVE-2020-1936, GHSA-q7q9-w24q-cpgh Record: https://patchnext.com/advisories/cve-2020-1936 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.ambari:ambari 2.7.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.ambari:ambari: affected < 2.7.4; fixed in 2.7.4 ## Suggested inspection (read-only) - Maven org.apache.ambari:ambari: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.ambari:ambari. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q7q9-w24q-cpgh (GitHub-reviewed advisory GHSA-q7q9-w24q-cpgh lists affected ranges: Maven org.apache.ambari:ambari >=0 <2.7.4) Commands are suggestions: review each one before running it.
Loading voting…