Skip to content

← Public intelligence

Maven package

org.apache.activemq:activemq-openwire-legacy

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9MavenPublished

    Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation

    CVE-2025-27533 · GHSA-whxr-3p84-rf3c

    Affected
    • Maven org.apache.activemq:activemq-openwire-legacy < 5.16.8; >= 5.17.0, < 5.17.7; >= 5.18.0, < 5.18.7; >= 6.0.0, < 6.1.6
    Fixed in
    5.17.75.16.86.1.65.18.7· Vendor fix available
    Issue
    Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ. During unmarshalling of OpenWire commands the size value of buffers was not properly validated which could lead to excessive memory allocation and be exploited to cause a denial of service (DoS) by depleting process memory, thereby affecting applications and services that rely on the availability of the ActiveMQ broker when not using mutual TLS connections. This issue affects Apache ActiveMQ: from 6.0.0 before 6.1.6, from 5.18.0 before 5.18.7, from 5.17.0 before 5.17.7, before 5.16.8. ActiveMQ 5.19.0 is not affected. Users are recommended to upgrade to version 6.1.6+, 5.19.0+, 5.18.7+, 5.17.7, or 5.16.8 or which fixes the issue. Existing users may implement mutual TLS to mitigate the risk on affected brokers.

    Recommended action: Upgrade to 6.1.6, 5.18.7, 5.17.7 or 5.16.8 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 10.0Exploited · CISA KEVMavenPublished

    Apache ActiveMQ is vulnerable to Remote Code Execution

    CVE-2023-46604 · GHSA-crg9-44h2-xw35

    Affected
    • Maven org.apache.activemq:activemq-openwire-legacy >= 5.8.0, < 5.15.16; >= 5.16.0, < 5.16.7; >= 5.17.0, < 5.17.6; >= 5.18.0, < 5.18.3
    Fixed in
    5.17.65.16.75.18.35.15.16· Vendor fix available
    Issue
    Apache ActiveMQ is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker with network access to a broker to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause the broker to instantiate any class on the classpath. Users are recommended to upgrade to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3, which fixes this issue.

    Recommended action: Upgrade to 5.18.3, 5.17.6, 5.16.7 or 5.15.16 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:cisa.gov (1)github.com (2)Source checked Evidence →