Skip to content

← Actionable
Critical, CVSS 10.0Exploited · CISA KEV

Apache ActiveMQ is vulnerable to Remote Code Execution

CVE-2023-46604GHSA-crg9-44h2-xw35

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-client 5.18.3, 5.17.6, 5.16.7, 5.15.16; org.apache.activemq:activemq-openwire-legacy 5.18.3, 5.17.6, 5.16.7, 5.15.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • CISA Known Exploited Vulnerabilities Catalog

    CISA added CVE-2023-46604 to the Known Exploited Vulnerabilities catalog on 2023-11-02.

    VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2023-11-02).

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-crg9-44h2-xw35 lists affected ranges: Maven org.apache.activemq:activemq-client >=0 =5.16.0 =5.17.0 =5.18.0 =5.8.0 =5.16.0 =5.17.0 =5.18.0 <5.18.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H/E:H
EPSS
  • CVE-2023-46604: 99.99% estimated exploitation activity in the next 30 days; percentile 99.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache ActiveMQ is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker with network access to a broker to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause the broker to instantiate any class on the classpath. Users are recommended to upgrade to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3, which fixes this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-crg9-44h2-xw35

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-46604

Advisory: Apache ActiveMQ is vulnerable to Remote Code Execution
IDs: CVE-2023-46604, GHSA-crg9-44h2-xw35
Record: https://patchnext.com/advisories/cve-2023-46604 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-client 5.18.3, 5.17.6, 5.16.7, 5.15.16; org.apache.activemq:activemq-openwire-legacy 5.18.3, 5.17.6, 5.16.7, 5.15.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.activemq:activemq-client: affected < 5.15.16; >= 5.16.0, < 5.16.7; >= 5.17.0, < 5.17.6; >= 5.18.0, < 5.18.3; fixed in 5.17.6, 5.16.7, 5.18.3, 5.15.16
- Maven org.apache.activemq:activemq-openwire-legacy: affected >= 5.8.0, < 5.15.16; >= 5.16.0, < 5.16.7; >= 5.17.0, < 5.17.6; >= 5.18.0, < 5.18.3; fixed in 5.17.6, 5.16.7, 5.18.3, 5.15.16

## Suggested inspection (read-only)
- Maven org.apache.activemq:activemq-client: check the installed version with your package manager.
- Maven org.apache.activemq:activemq-openwire-legacy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.activemq:activemq-client, org.apache.activemq:activemq-openwire-legacy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2023-46604 to the Known Exploited Vulnerabilities catalog on 2023-11-02.)
- Verified: https://github.com/advisories/GHSA-crg9-44h2-xw35 (GitHub-reviewed advisory GHSA-crg9-44h2-xw35 lists affected ranges: Maven org.apache.activemq:activemq-client >=0 =5.16.0 =5.17.0 =5.18.0 =5.8.0 =5.16.0 =5.17.0 =5.18.0 <5.18.3)

Commands are suggestions: review each one before running it.

Loading voting…