Skip to content

← Public intelligence

Maven package

net.ripe.rpki:rpki-validator-3

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Vulnerability in RPKI manifest validation

    GHSA-q76j-58cx-wp5v

    Affected
    • Maven net.ripe.rpki:rpki-validator-3 <= 3.2-2020.10.28.22.25
    Fixed in
    3.2-2020.10.28.23.06· Vendor fix available
    Issue
    A vulnerability in RPKI manifest validation exists when objects on the manifest are hidden, or expired objects are replayed. An attacker successfully exploiting this vulnerability could prevent new ROAs from being received or selectively hide ROAs, causing routes to become INVALID. To exploit this vulnerability, an attacker would need to perform a man in the middle attack on the TLS connection between the validator and an RRDP repository or perform a man in the middle attack against a rsync-only repository. The update addresses the vulnerability by implementing validation methods from RFC 6486bis and enabling strict validation by default.

    Recommended action: Upgrade to 3.2-2020.10.28.23.06 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →