Skip to content

← Actionable
Unrated

Vulnerability in RPKI manifest validation

GHSA-q76j-58cx-wp5v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (net.ripe.rpki:rpki-validator-3 3.2-2020.10.28.23.06), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in RPKI manifest validation exists when objects on the manifest are hidden, or expired objects are replayed. An attacker successfully exploiting this vulnerability could prevent new ROAs from being received or selectively hide ROAs, causing routes to become INVALID. To exploit this vulnerability, an attacker would need to perform a man in the middle attack on the TLS connection between the validator and an RRDP repository or perform a man in the middle attack against a rsync-only repository. The update addresses the vulnerability by implementing validation methods from RFC 6486bis and enabling strict validation by default.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q76j-58cx-wp5v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-q76j-58cx-wp5v

Advisory: Vulnerability in RPKI manifest validation
IDs: GHSA-q76j-58cx-wp5v
Record: https://patchnext.com/advisories/ghsa-q76j-58cx-wp5v (revision 1, source checked 26 Oct 2026, 15:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: net.ripe.rpki:rpki-validator-3 3.2-2020.10.28.23.06. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven net.ripe.rpki:rpki-validator-3: affected <= 3.2-2020.10.28.22.25; fixed in 3.2-2020.10.28.23.06

## Suggested inspection (read-only)
- Maven net.ripe.rpki:rpki-validator-3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on net.ripe.rpki:rpki-validator-3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q76j-58cx-wp5v (GitHub-reviewed advisory GHSA-q76j-58cx-wp5v lists affected ranges: Maven net.ripe.rpki:rpki-validator-3 >=0 <=3.2-2020.10.28.22.25)

Commands are suggestions: review each one before running it.

Loading voting…