Skip to content

← Public intelligence

Maven package

net.minidev:json-smart

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Netplex Json-smart Uncontrolled Recursion vulnerability

    CVE-2024-57699 · GHSA-pq2g-wx69-c263

    Affected
    • Maven net.minidev:json-smart >= 2.5.0, < 2.5.2
    Fixed in
    2.5.2· Vendor fix available
    Issue
    A security issue was found in Netplex Json-smart 2.5.0 through 2.5.1. When loading a specially crafted JSON input, containing a large number of ’{’, a stack exhaustion can be trigger, which could allow an attacker to cause a Denial of Service (DoS). This issue exists because of an incomplete fix for CVE-2023-1370. The fixed version only addresses the default modes provided by JSONParser, such as MODERFC4627. If you create the JSONParser manually or with custom options, make sure to set the LIMITJSONDEPTH option.

    Recommended action: Upgrade to 2.5.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    json-smart Uncontrolled Recursion vulnerability

    CVE-2023-1370 · GHSA-493p-pfq6-5258

    Affected
    • Maven net.minidev:json-smart < 2.4.9
    Fixed in
    2.4.9· Vendor fix available
    Issue
    Impact Affected versions of net.minidev:json-smart are vulnerable to Denial of Service (DoS) due to a StackOverflowError when parsing a deeply nested JSON array or object. When reaching a ‘‘ or ‘{‘ character in the JSON input, the code parses an array or an object respectively. It was discovered that the 3PP does not have any limit to the nesting of such arrays or objects. Since the parsing of nested arrays and objects is done recursively, nesting too many of them can cause stack exhaustion (stack overflow) and crash the software. Patches This vulnerability was fixed in json-smart version 2.4.9, but the maintainer recommends upgrading to 2.4.10, due to a remaining bug. Workarounds N/A References - https://www.cve.org/CVERecord?id=CVE-2023-1370 - https://nvd.nist.gov/vuln/detail/CVE-2023-1370 - https://security.snyk.io/vuln/SNYK-JAVA-NETMINIDEV-3369748

    Recommended action: Upgrade to 2.4.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    Out of bounds read in json-smart

    CVE-2021-31684 · GHSA-fg2v-w576-w4v3

    Affected
    • Maven net.minidev:json-smart >= 1.3.0, < 1.3.3; >= 2.4.0, < 2.4.4
    Fixed in
    1.3.32.4.4· Vendor fix available
    Issue
    A vulnerability was discovered in the indexOf function of JSONParserByteArray in JSON Smart versions prior to 1.3.3 and 2.4.5 which causes a denial of service (DOS) via a crafted web request.

    Recommended action: Upgrade to 2.4.4 or 1.3.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.9MavenPublished

    Improper Check for Unusual or Exceptional Conditions in json-smart

    CVE-2021-27568 · GHSA-v528-7hrm-frqp

    Affected
    • Maven net.minidev:json-smart < 1.3.2; >= 2.4.0, < 2.4.1; >= 2.0.0, < 2.3.1
    Fixed in
    2.4.11.3.22.3.1· Vendor fix available
    Issue
    An issue was discovered in netplex json-smart-v1 through 2015-10-23 and json-smart-v2 through 2.4. An exception is thrown from a function, but it is not caught, as demonstrated by NumberFormatException. When it is not caught, it may cause programs using the library to crash or expose sensitive information.

    Recommended action: Upgrade to 2.4.1, 2.3.1 or 1.3.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →