Skip to content

← Actionable
High, CVSS 7.5

Netplex Json-smart Uncontrolled Recursion vulnerability

CVE-2024-57699GHSA-pq2g-wx69-c263

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (net.minidev:json-smart 2.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-57699: 0.58% estimated exploitation activity in the next 30 days; percentile 47.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security issue was found in Netplex Json-smart 2.5.0 through 2.5.1. When loading a specially crafted JSON input, containing a large number of ’{’, a stack exhaustion can be trigger, which could allow an attacker to cause a Denial of Service (DoS). This issue exists because of an incomplete fix for CVE-2023-1370. The fixed version only addresses the default modes provided by JSONParser, such as MODERFC4627. If you create the JSONParser manually or with custom options, make sure to set the LIMITJSONDEPTH option.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pq2g-wx69-c263

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-57699

Advisory: Netplex Json-smart Uncontrolled Recursion vulnerability
IDs: CVE-2024-57699, GHSA-pq2g-wx69-c263
Record: https://patchnext.com/advisories/cve-2024-57699 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: net.minidev:json-smart 2.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven net.minidev:json-smart: affected >= 2.5.0, < 2.5.2; fixed in 2.5.2

## Suggested inspection (read-only)
- Maven net.minidev:json-smart: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on net.minidev:json-smart.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pq2g-wx69-c263 (GitHub-reviewed advisory GHSA-pq2g-wx69-c263 lists affected ranges: Maven net.minidev:json-smart >=2.5.0 <2.5.2)

Commands are suggestions: review each one before running it.

Loading voting…