Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
JavaMelody is a monitoring tool for JavaEE applications. Versions prior to 1.61.0 are vulnerable to a cross-site scripting (XSS) attack. This issue was patched in version 1.61.0, and users are recommended to upgrade to the latest version. There are no known workarounds.
Recommended action: Upgrade to 1.61.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Cross-site scripting (XSS) vulnerability in HtmlSessionInformationsReport.java in JavaMelody 1.46 and earlier allows remote attackers to inject arbitrary web script or HTML via a crafted X-Forwarded-For header.
Recommended action: Upgrade to 1.47.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
JavaMelody through 1.60.0 has XSS via the counter parameter in a clearcounter action to the /monitoring URI.
Recommended action: Upgrade to 1.61.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
JavaMelody before 1.74.0 has XXE via parseSoapMethodName in bull/javamelody/PayloadNameRequestWrapper.java.
Recommended action: Upgrade to 1.74.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.