Java Melody vulnerable to cross-site scripting
CVE-2016-1000273GHSA-cqhr-jqvc-qw9p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net.bull.javamelody:javamelody-core 1.61.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven net.bull.javamelody:javamelody-core
- Affected
- < 1.61.0
- Fixed in
- 1.61.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cqhr-jqvc-qw9p lists affected ranges: Maven net.bull.javamelody:javamelody-core >=0 <1.61.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
JavaMelody is a monitoring tool for JavaEE applications. Versions prior to 1.61.0 are vulnerable to a cross-site scripting (XSS) attack. This issue was patched in version 1.61.0, and users are recommended to upgrade to the latest version. There are no known workarounds.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cqhr-jqvc-qw9p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-1000273 Advisory: Java Melody vulnerable to cross-site scripting IDs: CVE-2016-1000273, GHSA-cqhr-jqvc-qw9p Record: https://patchnext.com/advisories/cve-2016-1000273 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net.bull.javamelody:javamelody-core 1.61.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven net.bull.javamelody:javamelody-core: affected < 1.61.0; fixed in 1.61.0 ## Suggested inspection (read-only) - Maven net.bull.javamelody:javamelody-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net.bull.javamelody:javamelody-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cqhr-jqvc-qw9p (GitHub-reviewed advisory GHSA-cqhr-jqvc-qw9p lists affected ranges: Maven net.bull.javamelody:javamelody-core >=0 <1.61.0) Commands are suggestions: review each one before running it.
Loading voting…