Skip to content

← Public intelligence

Maven package

it.geosolutions.jaiext.jiffle:jt-jiffle-language

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8Exploited · CISA KEVMavenPublished

    Improper Control of Generation of Code ('Code Injection') in jai-ext

    CVE-2022-24816 · GHSA-v92f-jx6p-73rx

    Affected
    • Maven it.geosolutions.jaiext.jiffle:jt-jiffle-language < 1.1.22
    Fixed in
    1.1.22· Vendor fix available
    Issue
    Impact Programs using jt-jiffle, and allowing Jiffle script to be provided via network request, are susceptible to a Remote Code Execution as the Jiffle script is compiled into Java code via Janino, and executed. In particular, this affects the downstream GeoServer project. Patches Version 1.2.22 will contain a patch that disables the ability to inject malicious code into the resulting script. Workarounds Negate the ability to compile Jiffle scripts from the final application, by removing janino-x.y.z.jar from the classpath. References None.

    Recommended action: Upgrade to 1.1.22 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)cisa.gov (2)Source checked Evidence →