Skip to content

← Actionable
Critical, CVSS 9.8Exploited · CISA KEV

Improper Control of Generation of Code ('Code Injection') in jai-ext

CVE-2022-24816GHSA-v92f-jx6p-73rx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (it.geosolutions.jaiext.jiffle:jt-jiffle-language 1.1.22; it.geosolutions.jaiext.jiffle:jt-jiffle 1.1.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2022-24816: 99.93% estimated exploitation activity in the next 30 days; percentile 99.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Programs using jt-jiffle, and allowing Jiffle script to be provided via network request, are susceptible to a Remote Code Execution as the Jiffle script is compiled into Java code via Janino, and executed. In particular, this affects the downstream GeoServer project. Patches Version 1.2.22 will contain a patch that disables the ability to inject malicious code into the resulting script. Workarounds Negate the ability to compile Jiffle scripts from the final application, by removing janino-x.y.z.jar from the classpath. References None.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v92f-jx6p-73rx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24816

Advisory: Improper Control of Generation of Code ('Code Injection') in jai-ext
IDs: CVE-2022-24816, GHSA-v92f-jx6p-73rx
Record: https://patchnext.com/advisories/cve-2022-24816 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: it.geosolutions.jaiext.jiffle:jt-jiffle-language 1.1.22; it.geosolutions.jaiext.jiffle:jt-jiffle 1.1.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven it.geosolutions.jaiext.jiffle:jt-jiffle-language: affected < 1.1.22; fixed in 1.1.22
- Maven it.geosolutions.jaiext.jiffle:jt-jiffle: affected < 1.1.22; fixed in 1.1.22

## Suggested inspection (read-only)
- Maven it.geosolutions.jaiext.jiffle:jt-jiffle-language: check the installed version with your package manager.
- Maven it.geosolutions.jaiext.jiffle:jt-jiffle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on it.geosolutions.jaiext.jiffle:jt-jiffle-language, it.geosolutions.jaiext.jiffle:jt-jiffle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v92f-jx6p-73rx (GitHub-reviewed advisory GHSA-v92f-jx6p-73rx lists affected ranges: Maven it.geosolutions.jaiext.jiffle:jt-jiffle >=0 =0 <1.1.22)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2022-24816 to the Known Exploited Vulnerabilities catalog on 2024-06-26.)

Commands are suggestions: review each one before running it.

Loading voting…