Skip to content

← Public intelligence

Maven package

io.swagger:swagger-parser

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8MavenPublished

    Deserialization of Untrusted Data in swagger-parser

    CVE-2017-1000208 · GHSA-q7pf-qr96-2vq5

    Affected
    • Maven io.swagger:swagger-parser < 1.0.31
    Fixed in
    1.0.31· Vendor fix available
    Issue
    A vulnerability in Swagger-Parser's (version <= 1.0.30) yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.

    Recommended action: Upgrade to 1.0.31 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    Deserialization of Untrusted Data in swagger-codegen

    CVE-2017-1000207 · GHSA-vgvf-9jh3-fg75

    Affected
    • Maven io.swagger:swagger-parser < 1.0.31
    Fixed in
    1.0.31· Vendor fix available
    Issue
    A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.

    Recommended action: Upgrade to 1.0.31 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →