Deserialization of Untrusted Data in swagger-codegen
CVE-2017-1000207GHSA-vgvf-9jh3-fg75
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.swagger:swagger-parser 1.0.31; io.swagger:swagger-codegen 2.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.swagger:swagger-parser
- Affected
- < 1.0.31
- Fixed in
- 1.0.31
Maven io.swagger:swagger-codegen
- Affected
- < 2.2.2
- Fixed in
- 2.2.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vgvf-9jh3-fg75 lists affected ranges: Maven io.swagger:swagger-parser >=0 =0 <2.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-1000207: 1.62% estimated exploitation activity in the next 30 days; percentile 76.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vgvf-9jh3-fg75
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-1000207 Advisory: Deserialization of Untrusted Data in swagger-codegen IDs: CVE-2017-1000207, GHSA-vgvf-9jh3-fg75 Record: https://patchnext.com/advisories/cve-2017-1000207 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.swagger:swagger-parser 1.0.31; io.swagger:swagger-codegen 2.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.swagger:swagger-parser: affected < 1.0.31; fixed in 1.0.31 - Maven io.swagger:swagger-codegen: affected < 2.2.2; fixed in 2.2.2 ## Suggested inspection (read-only) - Maven io.swagger:swagger-parser: check the installed version with your package manager. - Maven io.swagger:swagger-codegen: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.swagger:swagger-parser, io.swagger:swagger-codegen. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vgvf-9jh3-fg75 (GitHub-reviewed advisory GHSA-vgvf-9jh3-fg75 lists affected ranges: Maven io.swagger:swagger-parser >=0 =0 <2.2.2) Commands are suggestions: review each one before running it.
Loading voting…