Critical, CVSS 9.8MavenPublished
Code injection in quarkus dev ui config editor
CVE-2022-4116 · GHSA-g56w-cwg4-hxx9
- Affected
- Maven io.quarkus:quarkus-vertx-http-deployment >= 2.14.0, < 2.14.2.Final; < 2.13.5.Final
- Fixed in
- 2.14.2.Final2.13.5.Final· Vendor fix available
- Issue
- A vulnerability was found in quarkus. This security flaw happens in Dev UI Config Editor which is vulnerable to drive-by localhost attacks leading to remote code execution.
Recommended action: Upgrade to 2.14.2.Final or 2.13.5.Final by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.