Skip to content

← Actionable
Critical, CVSS 9.8

Code injection in quarkus dev ui config editor

CVE-2022-4116GHSA-g56w-cwg4-hxx9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.quarkus:quarkus-vertx-http-deployment 2.14.2.Final, 2.13.5.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-4116: 32.52% estimated exploitation activity in the next 30 days; percentile 98.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in quarkus. This security flaw happens in Dev UI Config Editor which is vulnerable to drive-by localhost attacks leading to remote code execution.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g56w-cwg4-hxx9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-4116

Advisory: Code injection in quarkus dev ui config editor
IDs: CVE-2022-4116, GHSA-g56w-cwg4-hxx9
Record: https://patchnext.com/advisories/cve-2022-4116 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.quarkus:quarkus-vertx-http-deployment 2.14.2.Final, 2.13.5.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.quarkus:quarkus-vertx-http-deployment: affected >= 2.14.0, < 2.14.2.Final; < 2.13.5.Final; fixed in 2.14.2.Final, 2.13.5.Final

## Suggested inspection (read-only)
- Maven io.quarkus:quarkus-vertx-http-deployment: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.quarkus:quarkus-vertx-http-deployment.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g56w-cwg4-hxx9 (GitHub-reviewed advisory GHSA-g56w-cwg4-hxx9 lists affected ranges: Maven io.quarkus:quarkus-vertx-http-deployment >=2.14.0 =0 <2.13.5.Final)

Commands are suggestions: review each one before running it.

Loading voting…