High, CVSS 8.1MavenPublished
Quarkus HTTP vulnerable to incorrect evaluation of permissions
CVE-2023-4853 · GHSA-4f4r-wgv2-jjvg
- Affected
- Maven io.quarkus:quarkus-csrf-reactive < 2.16.11.Final; >= 3.0.0, < 3.2.6.Final; >= 3.3.0, < 3.3.3
- Fixed in
- 2.16.11.Final3.3.33.2.6.Final· Vendor fix available
- Issue
- A flaw was found in Quarkus where HTTP security policies are not sanitizing certain character permutations correctly when accepting requests, resulting in incorrect evaluation of permissions. This issue could allow an attacker to bypass the security policy altogether, resulting in unauthorized endpoint access and possibly a denial of service.
Recommended action: Upgrade to 3.3.3, 3.2.6.Final or 2.16.11.Final by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.