Skip to content

← Actionable
High, CVSS 8.1

Quarkus HTTP vulnerable to incorrect evaluation of permissions

CVE-2023-4853GHSA-4f4r-wgv2-jjvg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.quarkus:quarkus-vertx-http 3.3.3, 3.2.6.Final, 2.16.11.Final; io.quarkus:quarkus-csrf-reactive 3.3.3, 3.2.6.Final, 2.16.11.Final; io.quarkus:quarkus-undertow 3.3.3, 3.2.6.Final, 2.16.11.Final; io.quarkus:quarkus-keycloak-authorization 3.3.3, 3.2.6.Final, 2.16.11.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4f4r-wgv2-jjvg lists affected ranges: Maven io.quarkus:quarkus-vertx-http >=0 =3.0.0 =3.3.0 =0 =3.0.0 =3.3.0 =0 =3.0.0 =3.3.0 =0 =3.0.0 =3.3.0 <3.3.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-4853: 1.45% estimated exploitation activity in the next 30 days; percentile 73.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in Quarkus where HTTP security policies are not sanitizing certain character permutations correctly when accepting requests, resulting in incorrect evaluation of permissions. This issue could allow an attacker to bypass the security policy altogether, resulting in unauthorized endpoint access and possibly a denial of service.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4f4r-wgv2-jjvg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-4853

Advisory: Quarkus HTTP vulnerable to incorrect evaluation of permissions
IDs: CVE-2023-4853, GHSA-4f4r-wgv2-jjvg
Record: https://patchnext.com/advisories/cve-2023-4853 (revision 1, source checked 26 Oct 2026, 16:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.quarkus:quarkus-vertx-http 3.3.3, 3.2.6.Final, 2.16.11.Final; io.quarkus:quarkus-csrf-reactive 3.3.3, 3.2.6.Final, 2.16.11.Final; io.quarkus:quarkus-undertow 3.3.3, 3.2.6.Final, 2.16.11.Final; io.quarkus:quarkus-keycloak-authorization 3.3.3, 3.2.6.Final, 2.16.11.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.quarkus:quarkus-vertx-http: affected < 2.16.11.Final; >= 3.0.0, < 3.2.6.Final; >= 3.3.0, < 3.3.3; fixed in 2.16.11.Final, 3.3.3, 3.2.6.Final
- Maven io.quarkus:quarkus-csrf-reactive: affected < 2.16.11.Final; >= 3.0.0, < 3.2.6.Final; >= 3.3.0, < 3.3.3; fixed in 2.16.11.Final, 3.3.3, 3.2.6.Final
- Maven io.quarkus:quarkus-undertow: affected < 2.16.11.Final; >= 3.0.0, < 3.2.6.Final; >= 3.3.0, < 3.3.3; fixed in 2.16.11.Final, 3.3.3, 3.2.6.Final
- Maven io.quarkus:quarkus-keycloak-authorization: affected < 2.16.11.Final; >= 3.0.0, < 3.2.6.Final; >= 3.3.0, < 3.3.3; fixed in 2.16.11.Final, 3.3.3, 3.2.6.Final

## Suggested inspection (read-only)
- Maven io.quarkus:quarkus-vertx-http: check the installed version with your package manager.
- Maven io.quarkus:quarkus-csrf-reactive: check the installed version with your package manager.
- Maven io.quarkus:quarkus-undertow: check the installed version with your package manager.
- Maven io.quarkus:quarkus-keycloak-authorization: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.quarkus:quarkus-vertx-http, io.quarkus:quarkus-csrf-reactive, io.quarkus:quarkus-undertow, io.quarkus:quarkus-keycloak-authorization.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4f4r-wgv2-jjvg (GitHub-reviewed advisory GHSA-4f4r-wgv2-jjvg lists affected ranges: Maven io.quarkus:quarkus-vertx-http >=0 =3.0.0 =3.3.0 =0 =3.0.0 =3.3.0 =0 =3.0.0 =3.3.0 =0 =3.0.0 =3.3.0 <3.3.3)

Commands are suggestions: review each one before running it.

Loading voting…