Skip to content

← Public intelligence

Maven package

io.projectreactor.netty:reactor-netty-http

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Reactor Netty HTTP is vulnerable to credential leaks during chained redirects

    CVE-2025-22227 · GHSA-4q2v-9p7v-3v22

    Affected
    • Maven io.projectreactor.netty:reactor-netty-http >= 1.3.0-M1, < 1.3.0-M5; < 1.2.8
    Fixed in
    1.2.81.3.0-M5· Vendor fix available
    Issue
    In some specific scenarios with chained redirects, Reactor Netty HTTP client leaks credentials. In order for this to happen, the HTTP client must have been explicitly configured to follow redirects.

    Recommended action: Upgrade to 1.3.0-M5 (pre-release) or 1.2.8 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    In Reactor Netty HTTP Server a malicious user can send a request using a specially crafted URL that can lead to a directory traversal attack

    CVE-2023-34062 · GHSA-xjhv-p3fv-x24r

    Affected
    • Maven io.projectreactor.netty:reactor-netty-http >= 1.1.0, < 1.1.13; >= 1.0.0, < 1.0.39
    Fixed in
    1.0.391.1.13· Vendor fix available
    Issue
    In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, a malicious user can send a request using a specially crafted URL that can lead to a directory traversal attack. Specifically, an application is vulnerable if Reactor Netty HTTP Server is configured to serve static resources.

    Recommended action: Upgrade to 1.1.13 or 1.0.39 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.3MavenPublished

    Invalid HTTP requests in Reactor Netty HTTP Server may reveal access tokens

    CVE-2022-31684 · GHSA-7w4x-4h67-pgmv

    Affected
    • Maven io.projectreactor.netty:reactor-netty-http >= 1.0.11, < 1.0.24
    Fixed in
    1.0.24· Vendor fix available
    Issue
    Reactor Netty HTTP Server, in versions 1.0.11 - 1.0.23, may request log headers in some cases of invalid HTTP requests. The logged headers may reveal valid access tokens to those with access to server logs. This may affect only invalid HTTP requests where logging at WARN level is enabled.

    Recommended action: Upgrade to 1.0.24 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Improper Handling of Exceptional Conditions and Improper Input Validation in Reactor Netty

    CVE-2020-5403 · GHSA-hp5x-rqf7-43vf

    Affected
    • Maven io.projectreactor.netty:reactor-netty-http >= 0.9.3, <= 0.9.4
    Fixed in
    0.9.5· Vendor fix available
    Issue
    Reactor Netty HttpServer, versions 0.9.3 and 0.9.4, is exposed to a URISyntaxException that causes the connection to be closed prematurely instead of producing a 400 response.

    Recommended action: Upgrade to 0.9.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 5.9MavenPublished

    Insufficiently Protected Credentials in Reactor Netty

    CVE-2020-5404 · GHSA-gpch-h32j-gx6x

    Affected
    • Maven io.projectreactor.netty:reactor-netty-http >= 0.9.0, < 0.9.5; >= 0.8.0, < 0.8.16
    Fixed in
    0.9.50.8.16· Vendor fix available
    Issue
    The HttpClient from Reactor Netty, versions 0.9.x prior to 0.9.5, and versions 0.8.x prior to 0.8.16, may be used incorrectly, leading to a credentials leak during a redirect to a different domain. In order for this to happen, the HttpClient must have been explicitly configured to follow redirects.

    Recommended action: Upgrade to 0.9.5 or 0.8.16 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →