Improper Handling of Exceptional Conditions and Improper Input Validation in Reactor Netty
CVE-2020-5403GHSA-hp5x-rqf7-43vf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.projectreactor.netty:reactor-netty-http 0.9.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.projectreactor.netty:reactor-netty-http
- Affected
- >= 0.9.3, <= 0.9.4
- Fixed in
- 0.9.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hp5x-rqf7-43vf lists affected ranges: Maven io.projectreactor.netty:reactor-netty-http >=0.9.3 <=0.9.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-5403: 1.16% estimated exploitation activity in the next 30 days; percentile 67.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Reactor Netty HttpServer, versions 0.9.3 and 0.9.4, is exposed to a URISyntaxException that causes the connection to be closed prematurely instead of producing a 400 response.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hp5x-rqf7-43vf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5403 Advisory: Improper Handling of Exceptional Conditions and Improper Input Validation in Reactor Netty IDs: CVE-2020-5403, GHSA-hp5x-rqf7-43vf Record: https://patchnext.com/advisories/cve-2020-5403 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.projectreactor.netty:reactor-netty-http 0.9.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.projectreactor.netty:reactor-netty-http: affected >= 0.9.3, <= 0.9.4; fixed in 0.9.5 ## Suggested inspection (read-only) - Maven io.projectreactor.netty:reactor-netty-http: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.projectreactor.netty:reactor-netty-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hp5x-rqf7-43vf (GitHub-reviewed advisory GHSA-hp5x-rqf7-43vf lists affected ranges: Maven io.projectreactor.netty:reactor-netty-http >=0.9.3 <=0.9.4) Commands are suggestions: review each one before running it.
Loading voting…