UnratedMavenPublished
Netty denial of service vulnerability
CVE-2014-0193 · GHSA-7vpq-g998-qpv7
- Affected
- Maven io.netty:netty-all >= 4.0.0.Alpha1, < 4.0.19.Final
- Fixed in
- 4.0.19.Final· Vendor fix available
- Issue
- WebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a TextWebSocketFrame followed by a long stream of ContinuationWebSocketFrames.
Recommended action: Upgrade to 4.0.19.Final or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.