Skip to content

← Actionable
Unrated

Netty denial of service vulnerability

CVE-2014-0193GHSA-7vpq-g998-qpv7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-all 4.0.19.Final; io.netty:netty 4.0.19.Final, 3.9.1.Final, 3.8.2.Final, 3.7.1.Final, 3.6.9.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.netty:netty-all

    Affected
    >= 4.0.0.Alpha1, < 4.0.19.Final
    Fixed in
    4.0.19.Final
  • Maven io.netty:netty

    Affected
    >= 3.6.0.Beta1, < 3.6.9.Final>= 3.7.0.Final, < 3.7.1.Final>= 3.8.0.Final, < 3.8.2.Final>= 3.9.0.Final, < 3.9.1.Final>= 4.0.0.Alpha1, < 4.0.19.Final
    Fixed in
    4.0.19.Final, 3.7.1.Final, 3.6.9.Final, 3.9.1.Final, 3.8.2.Final

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-7vpq-g998-qpv7 lists affected ranges: Maven io.netty:netty >=3.6.0.Beta1 =3.7.0.Final =3.8.0.Final =3.9.0.Final =4.0.0.Alpha1 =4.0.0.Alpha1 <4.0.19.Final

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-0193: 4.33% estimated exploitation activity in the next 30 days; percentile 91.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

WebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a TextWebSocketFrame followed by a long stream of ContinuationWebSocketFrames.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7vpq-g998-qpv7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-0193

Advisory: Netty denial of service vulnerability
IDs: CVE-2014-0193, GHSA-7vpq-g998-qpv7
Record: https://patchnext.com/advisories/cve-2014-0193 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-all 4.0.19.Final; io.netty:netty 4.0.19.Final, 3.9.1.Final, 3.8.2.Final, 3.7.1.Final, 3.6.9.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-all: affected >= 4.0.0.Alpha1, < 4.0.19.Final; fixed in 4.0.19.Final
- Maven io.netty:netty: affected >= 3.6.0.Beta1, < 3.6.9.Final; >= 3.7.0.Final, < 3.7.1.Final; >= 3.8.0.Final, < 3.8.2.Final; >= 3.9.0.Final, < 3.9.1.Final; >= 4.0.0.Alpha1, < 4.0.19.Final; fixed in 4.0.19.Final, 3.7.1.Final, 3.6.9.Final, 3.9.1.Final, 3.8.2.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-all: check the installed version with your package manager.
- Maven io.netty:netty: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-all, io.netty:netty.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7vpq-g998-qpv7 (GitHub-reviewed advisory GHSA-7vpq-g998-qpv7 lists affected ranges: Maven io.netty:netty >=3.6.0.Beta1 =3.7.0.Final =3.8.0.Final =3.9.0.Final =4.0.0.Alpha1 =4.0.0.Alpha1 <4.0.19.Final)

Commands are suggestions: review each one before running it.

Loading voting…