Skip to content

← Public intelligence

Maven package

io.jenkins.plugins:warnings-ng

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Jenkins Warnings Plugin exposures system-scoped credentials

    CVE-2023-46651 · GHSA-66hv-fhcm-7xm7

    Affected
    • Maven io.jenkins.plugins:warnings-ng >= 10.5.0, <= 10.5.0; < 10.4.1
    Fixed in
    10.4.110.5.1· Vendor fix available
    Issue
    Jenkins Warnings Plugin 10.5.0 and earlier does not set the appropriate context for credentials lookup, allowing the use of system-scoped credentials otherwise reserved for the global configuration. This allows attackers with Item/Configure permission to access and capture credentials they are not entitled to. Warnings Plugin 10.5.1 defines the appropriate context for credentials lookup. This fix has been backported to 10.4.1.

    Recommended action: Upgrade to 10.5.1 or 10.4.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Jenkins Warnings NG Plugin cross-site request forgery vulnerability

    CVE-2019-10326 · GHSA-px35-882c-47hw

    Affected
    • Maven io.jenkins.plugins:warnings-ng < 5.1.0
    Fixed in
    5.1.0· Vendor fix available
    Issue
    A cross-site request forgery vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attackers to reset warning counts for future builds.

    Recommended action: Upgrade to 5.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Jenkins Warnings NG Plugin Cross-site scripting vulnerability

    CVE-2019-10325 · GHSA-wrr5-p265-7252

    Affected
    • Maven io.jenkins.plugins:warnings-ng <= 5.0.0
    Fixed in
    5.1.0· Vendor fix available
    Issue
    A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.

    Recommended action: Upgrade to 5.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 4.3MavenPublished

    Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents

    CVE-2021-21626 · GHSA-7j3x-xm4j-jfj7

    Affected
    • Maven io.jenkins.plugins:warnings-ng <= 8.4.4
    Fixed in
    8.5.0· Vendor fix available
    Issue
    Jenkins Warnings Next Generation Plugin 8.4.4 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Item/Read permission but without Item/Workspace or Item/Configure permission to check whether attacker-specified file patterns match workspace contents. A sequence of requests can be used to effectively list workspace contents. Jenkins Warnings Next Generation Plugin 8.5.0 requires Item/Configure permission to validate patterns with workspace contents.

    Recommended action: Upgrade to 8.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.1MavenPublished

    XSS vulnerability in Jenkins Warnings Next Generation Plugin

    CVE-2019-1003023 · GHSA-cqp7-hwm3-cfg7

    Affected
    • Maven io.jenkins.plugins:warnings-ng <= 1.0.1
    Fixed in
    2.0.0· Vendor fix available
    Issue
    A cross-site scripting vulnerability exists in Jenkins Warnings Next Generation Plugin 1.0.1 and earlier in src/main/java/io/jenkins/plugins/analysis/core/model/DetailsTableModel.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourceDetail.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourcePrinter.java, src/main/java/io/jenkins/plugins/analysis/core/util/Sanitizer.java, src/main/java/io/jenkins/plugins/analysis/warnings/DuplicateCodeScanner.java that allows attackers with the ability to control warnings parser input to have Jenkins render arbitrary HTML.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 8.1MavenPublished

    Path Traversal in Jenkins Warnings Next Generation Plugin

    CVE-2022-23107 · GHSA-rvh4-g2rj-hr9c

    Affected
    • Maven io.jenkins.plugins:warnings-ng >= 9.8.0, < 9.10.3; >= 9.6.0, < 9.7.1; >= 9.1.0, < 9.5.2; < 9.0.2
    Fixed in
    9.0.29.5.29.10.39.7.1· Vendor fix available
    Issue
    Jenkins Warnings Next Generation Plugin prior to 9.10.3, 9.7.1, 9.5.2, and 9.0.2 does not restrict the name of a file when configuring a custom ID. This allows attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system. Jenkins Warnings Next Generation Plugin 9.10.3, 9.7.1, 9.5.2, and 9.0.2 checks for the presence of prohibited directory separator characters in the custom ID.

    Recommended action: Upgrade to 9.10.3, 9.7.1, 9.5.2 or 9.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →