Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents
CVE-2021-21626GHSA-7j3x-xm4j-jfj7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.plugins:warnings-ng 8.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jenkins.plugins:warnings-ng
- Affected
- <= 8.4.4
- Fixed in
- 8.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7j3x-xm4j-jfj7 lists affected ranges: Maven io.jenkins.plugins:warnings-ng >=0 <=8.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2021-21626: 0.86% estimated exploitation activity in the next 30 days; percentile 58.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Warnings Next Generation Plugin 8.4.4 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Item/Read permission but without Item/Workspace or Item/Configure permission to check whether attacker-specified file patterns match workspace contents. A sequence of requests can be used to effectively list workspace contents. Jenkins Warnings Next Generation Plugin 8.5.0 requires Item/Configure permission to validate patterns with workspace contents.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7j3x-xm4j-jfj7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21626 Advisory: Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents IDs: CVE-2021-21626, GHSA-7j3x-xm4j-jfj7 Record: https://patchnext.com/advisories/cve-2021-21626 (revision 1, source checked 26 Oct 2026, 16:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jenkins.plugins:warnings-ng 8.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jenkins.plugins:warnings-ng: affected <= 8.4.4; fixed in 8.5.0 ## Suggested inspection (read-only) - Maven io.jenkins.plugins:warnings-ng: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jenkins.plugins:warnings-ng. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7j3x-xm4j-jfj7 (GitHub-reviewed advisory GHSA-7j3x-xm4j-jfj7 lists affected ranges: Maven io.jenkins.plugins:warnings-ng >=0 <=8.4.4) Commands are suggestions: review each one before running it.
Loading voting…