Skip to content

← Public intelligence

Maven package

io.jenkins.plugins:atlassian-bitbucket-server-integration

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8MavenPublished

    Bitbucket Server Integration Plugin allows bypassing CSRF protection for any URL

    CVE-2025-24398 · GHSA-qjw6-xvrm-5f2h

    Affected
    • Maven io.jenkins.plugins:atlassian-bitbucket-server-integration >= 2.1.0, < 4.1.4
    Fixed in
    4.1.4· Vendor fix available
    Issue
    An extension point in Jenkins allows selectively disabling cross-site request forgery (CSRF) protection for specific URLs. Bitbucket Server Integration Plugin implements this extension point to support OAuth 1.0 authentication. In Bitbucket Server Integration Plugin 2.1.0 through 4.1.3 (both inclusive) this implementation is too permissive, allowing attackers to craft URLs that would bypass the CSRF protection of any target URL. Bitbucket Server Integration Plugin 4.1.4 restricts which URLs it disables cross-site request forgery (CSRF) protection for to the URLs that needs it.

    Recommended action: Upgrade to 4.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4MavenPublished

    Stored XSS vulnerability in Jenkins Bitbucket Server Integration Plugin

    CVE-2022-28133 · GHSA-45v7-65q8-x294

    Affected
    • Maven io.jenkins.plugins:atlassian-bitbucket-server-integration >= 2.0.0, < 3.2.0
    Fixed in
    3.2.0· Vendor fix available
    Issue
    Jenkins Bitbucket Server Integration Plugin 3.1.0 and earlier does not limit URL schemes for callback URLs on OAuth consumers, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to create BitBucket Server consumers.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Missing permission checks in Jekins Bitbucket Server Integration Plugin

    CVE-2022-28134 · GHSA-r5r6-v8qh-pmpq

    Affected
    • Maven io.jenkins.plugins:atlassian-bitbucket-server-integration < 3.2.0
    Fixed in
    3.2.0· Vendor fix available
    Issue
    Jenkins Bitbucket Server Integration Plugin 3.1.0 and earlier does not perform permission checks in several HTTP endpoints, allowing attackers with Overall/Read permission to create, view, and delete BitBucket Server consumers.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →