Bitbucket Server Integration Plugin allows bypassing CSRF protection for any URL
CVE-2025-24398GHSA-qjw6-xvrm-5f2h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.plugins:atlassian-bitbucket-server-integration 4.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jenkins.plugins:atlassian-bitbucket-server-integration
- Affected
- >= 2.1.0, < 4.1.4
- Fixed in
- 4.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qjw6-xvrm-5f2h lists affected ranges: Maven io.jenkins.plugins:atlassian-bitbucket-server-integration >=2.1.0 <4.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-24398: 0.30% estimated exploitation activity in the next 30 days; percentile 23.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An extension point in Jenkins allows selectively disabling cross-site request forgery (CSRF) protection for specific URLs. Bitbucket Server Integration Plugin implements this extension point to support OAuth 1.0 authentication. In Bitbucket Server Integration Plugin 2.1.0 through 4.1.3 (both inclusive) this implementation is too permissive, allowing attackers to craft URLs that would bypass the CSRF protection of any target URL. Bitbucket Server Integration Plugin 4.1.4 restricts which URLs it disables cross-site request forgery (CSRF) protection for to the URLs that needs it.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qjw6-xvrm-5f2h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24398 Advisory: Bitbucket Server Integration Plugin allows bypassing CSRF protection for any URL IDs: CVE-2025-24398, GHSA-qjw6-xvrm-5f2h Record: https://patchnext.com/advisories/cve-2025-24398 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jenkins.plugins:atlassian-bitbucket-server-integration 4.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jenkins.plugins:atlassian-bitbucket-server-integration: affected >= 2.1.0, < 4.1.4; fixed in 4.1.4 ## Suggested inspection (read-only) - Maven io.jenkins.plugins:atlassian-bitbucket-server-integration: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jenkins.plugins:atlassian-bitbucket-server-integration. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qjw6-xvrm-5f2h (GitHub-reviewed advisory GHSA-qjw6-xvrm-5f2h lists affected ranges: Maven io.jenkins.plugins:atlassian-bitbucket-server-integration >=2.1.0 <4.1.4) Commands are suggestions: review each one before running it.
Loading voting…