Medium, CVSS 6.5MavenPublished
Apiman Manager API affected by Jackson denial of service vulnerability
GHSA-q95j-488q-5q3p
- Affected
- Maven io.apiman:apiman-manager-api-impl <= 2.2.3.Final
- Fixed in
- 3.0.0.Final· Vendor fix available
- Issue
- Impact Due to a vulnerability in jackson-databind <= 2.12.6.0, an authenticated attacker could craft an Apiman policy configuration which, when saved, may cause a denial of service on the Apiman Manager API. This does not affect the Apiman Gateway. Patches Upgrade to Apiman 3.0.0.Final or later. If you are using an older version of Apiman and need to remain on that version, contact your Apiman support provider for advice/long-term support. Workarounds If all users of the Apiman Manager are trusted then you may assess this is low risk, as an account is required to exploit the vulnerability. References Apiman maintainer and security contact: marc@blackparrotlabs.io https://nvd.nist.gov/vuln/detail/CVE-2020-36518 https://github.com/FasterXML/jackson-databind/issues/2816
Recommended action: Upgrade to 3.0.0.Final or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.