Apiman Manager API affected by Jackson denial of service vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.apiman:apiman-manager-api-impl 3.0.0.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.apiman:apiman-manager-api-impl
- Affected
- <= 2.2.3.Final
- Fixed in
- 3.0.0.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q95j-488q-5q3p lists affected ranges: Maven io.apiman:apiman-manager-api-impl >=0 <=2.2.3.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Due to a vulnerability in jackson-databind <= 2.12.6.0, an authenticated attacker could craft an Apiman policy configuration which, when saved, may cause a denial of service on the Apiman Manager API. This does not affect the Apiman Gateway. Patches Upgrade to Apiman 3.0.0.Final or later. If you are using an older version of Apiman and need to remain on that version, contact your Apiman support provider for advice/long-term support. Workarounds If all users of the Apiman Manager are trusted then you may assess this is low risk, as an account is required to exploit the vulnerability. References Apiman maintainer and security contact: marc@blackparrotlabs.io https://nvd.nist.gov/vuln/detail/CVE-2020-36518 https://github.com/FasterXML/jackson-databind/issues/2816
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q95j-488q-5q3p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-q95j-488q-5q3p Advisory: Apiman Manager API affected by Jackson denial of service vulnerability IDs: GHSA-q95j-488q-5q3p Record: https://patchnext.com/advisories/ghsa-q95j-488q-5q3p (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.apiman:apiman-manager-api-impl 3.0.0.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.apiman:apiman-manager-api-impl: affected <= 2.2.3.Final; fixed in 3.0.0.Final ## Suggested inspection (read-only) - Maven io.apiman:apiman-manager-api-impl: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.apiman:apiman-manager-api-impl. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q95j-488q-5q3p (GitHub-reviewed advisory GHSA-q95j-488q-5q3p lists affected ranges: Maven io.apiman:apiman-manager-api-impl >=0 <=2.2.3.Final) Commands are suggestions: review each one before running it.
Loading voting…