Skip to content

← Public intelligence

Maven package

com.xwiki.identity-oauth:identity-oauth-ui

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0MavenPublished

    XWiki Identity Oauth Privilege escalation (PR)/remote code execution from login screen through unescaped URL parameter

    CVE-2023-45144 · GHSA-h2rm-29ch-wfmh

    Affected
    • Maven com.xwiki.identity-oauth:identity-oauth-ui >= 1.0, < 1.6
    Fixed in
    1.6· Vendor fix available
    Issue
    Impact When login via the OAuth method, the identityOAuth parameters, sent in a GET request is vulnerable to XSS and XWiki syntax injection. This allows remote code execution via the groovy macro and thus affects the confidentiality, integrity and availability of the whole XWiki installation. The vulnerability is in this part of the code. Patches The issue has been fixed in Identity OAuth version 1.6 by https://github.com/xwikisas/identity-oauth/commit/d805d3154b17c6bf455ddf5deb0a3461a3833bc6 . The fix is in the content of the IdentityOAuth/LoginUIExtension file Workarounds There are no known workarounds besides upgrading. References Are there any links users can visit to find out more? Original report: https://jira.xwiki.org/browse/XWIKI-20719

    Recommended action: Upgrade to 1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →