Skip to content

← Actionable
Critical, CVSS 10.0

XWiki Identity Oauth Privilege escalation (PR)/remote code execution from login screen through unescaped URL parameter

CVE-2023-45144GHSA-h2rm-29ch-wfmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.xwiki.identity-oauth:identity-oauth-ui 1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-45144: 1.23% estimated exploitation activity in the next 30 days; percentile 69.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When login via the OAuth method, the identityOAuth parameters, sent in a GET request is vulnerable to XSS and XWiki syntax injection. This allows remote code execution via the groovy macro and thus affects the confidentiality, integrity and availability of the whole XWiki installation. The vulnerability is in this part of the code. Patches The issue has been fixed in Identity OAuth version 1.6 by https://github.com/xwikisas/identity-oauth/commit/d805d3154b17c6bf455ddf5deb0a3461a3833bc6 . The fix is in the content of the IdentityOAuth/LoginUIExtension file Workarounds There are no known workarounds besides upgrading. References Are there any links users can visit to find out more? Original report: https://jira.xwiki.org/browse/XWIKI-20719

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h2rm-29ch-wfmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-45144

Advisory: XWiki Identity Oauth Privilege escalation (PR)/remote code execution from login screen through unescaped URL parameter
IDs: CVE-2023-45144, GHSA-h2rm-29ch-wfmh
Record: https://patchnext.com/advisories/cve-2023-45144 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.xwiki.identity-oauth:identity-oauth-ui 1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.xwiki.identity-oauth:identity-oauth-ui: affected >= 1.0, < 1.6; fixed in 1.6

## Suggested inspection (read-only)
- Maven com.xwiki.identity-oauth:identity-oauth-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.xwiki.identity-oauth:identity-oauth-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h2rm-29ch-wfmh (GitHub-reviewed advisory GHSA-h2rm-29ch-wfmh lists affected ranges: Maven com.xwiki.identity-oauth:identity-oauth-ui >=1.0 <1.6)

Commands are suggestions: review each one before running it.

Loading voting…